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Getting Started

PixelScope-Optic Studio is a powerful image analysis program optimized for lens testing.
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The next page in this chapter gives a quick tour of PixelScope's features.
The remaining pages in this chapter will show you how to:

Display an image

Use the built-in help system
Pan and Zoom within the image
Make your first measurement
What to do next

TIP: |t ihisis your first exposure to PixelScope we recommend you take a moment to read the rest of this
chapter. This will teach you all the basic techniques you'll need to use PixelScope.

Continue to next page

A quick tour of PixelScope

The PixelScope window
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Live images are shown in the PixelScope window .. The mouse is used to drag a Selection area in this window
for analysis. Secondary Plot windows , like the one shown above, open automatically to display analysis results.

Pan and Zoom

PixelScope has powerful pan and zoom capability. It is possible to zoom in so that individual pixels are clearly

visible.

Stored images:

PixelScope can open and save images stored in .bmp format.

Live video:

PixelScope supports capture of live images from FireWire CCD cameras from ThorLabs at frame rates up to 30
frames per second. Currently supported cameras capture 640 x 480 pixels with a resolution of 8 bits grayscale.

TIP:

Tools and Wizards

Only one camera can be active at a time. However, it is possible to run multiple instances of PixelScope
at the same time. Each instance can display the output of a different camera.

Tools

Tools perform simple measurement tasks, and display results in a Plot window. Tools are available from the row
of buttons along the left edge of the PixelScope window and also from the Tools Menu. The picture below shows

the Histogram Tool.
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Wizards perform more complicated measurements, and display results a dedicated plot window. Wizards are

available from the Wizards Menu. The picture below shows the MTF Wizard:
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Hardware

The Camera dialog controls selection of the active camera, exposure, etc. The Camera dialog is located on the

Hardware menu.
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The Optical Hardware dialog is used to enter details of the system configuration. The Optical Hardware dialog is

located on the Hardware menu.

E1 Optical Hardware Configuration

Mates
Camera configured [T __ %
as & telescope &
(&)

Configuration:  Telescope
Focal length [mm) 200
Pixel size [um] 7.4

200 mm telescope j

Show Layaut I e E dit |

X

Source ] Filker ] Lens Under Test  Detector l Units ]

The Layout window displays a convenient summary of the current setup. The Layout window is located on the

Hardware menu.
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Continue to next page

Displaying an image

The PixelScope window

The PixelScope window appears when you start the program, and remains open as long as the program is
running. This window contains the video viewing area, menus for accessing all analysis functions, and buttons for
quick access to the functions used most often.
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Images can come from 3 sources

- Live video

If a camera is connected to the system, live video will automatically be displayed when you start the
program. If the window is black , the camera is connected and operating properly, but not very much light is
reaching the camera.. If this is not what you want, please see the section "Finding first light"

When no camera is connected the window will be blue , as shown above. If you wish to view live video
please plug in the camera and restart PixelScope. If the screen remains blue when you restart, please see
the section "Debugging a blue screen”

file://C:\Users\Sam Powers\AppData\Local\Temp\~hB8Bhtm 6/23/200!



Getting Starte Page6 of 14

- Afile:
Use the Load saved image option on the File menu to open any .bmp format file.

- The Clipboard
Use the Paste image from clipboard option on the Edit menu to paste an image from some other source.

TIP: PixelScope works on grayscale images. RGB image files may be opened, but the images are
internally converted to grayscale.

- Use the Open saved image ... command in the File menu to open a file.
- A good choice is the file named "plastic lens sample image.bmp."
- After you do so, the PixelScope window should look like this:
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Continue to next page

Using PixelScope's help system

PixelScope has extensive built-in help. The help system includes all the material in the written user's manual.

TIP: Help is Context-sensitive . For example, if you press F1 while a menu is open....

[ PixelScope - OpticStudio
File Edit Tools ‘Wizards | Hardware Help

Cptical Hardware, ..
Show System Stake

Camera. ., Ckrl+P
I"'|'|"-|'|-"|- (Zhr| 45

CEpl+

The help system opens at the location that describes that menu item.
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TIP: Getting more information:  Clicking on underlined text takes you to a page with a more detailed
discussion. To return to where you were, just click the back button on the help window:

B PowlSeoge - Dptic Sludio

Certerts | Search | Farvoctes |
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The PielScope window will appear

The back button is an important feature. If you aren't familiar with it, we urge you to practice using it
now. Try clicking on one of these topics for practice. When you are done reading, click on the back
button to return to this page.

How do | turn on the camera?
How do | zoom in on part of the image?

Continue to next page

Finding first light

Finding the image can be surprisingly difficult the first time you set up the system. As you gain experience,
finding the image will become easy, but the first time it can be frustrating! Here are some tips to get you started:

Make sure the camera is turned on
If the screen is blue, the program has not detected a camera. If the screen is black, then the camera is on.

Set the exposure to a reasonable value

The camera has a very wide range of possible exposure values. Open the camera dialog to make sure the
exposure time is not set to a very small value.
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Carefully align the components

Page8 of 14

Make sure that the collimator, lens under test, and microscope all fall on the same line. You won't be able to do
this perfectly by eye, but you can usually come close enough for a first pass.

Carefully set the microscope axial location

If you are not sure of the location of the image formed by your lens,you usually find it with a white card.

TIP:

TIP:

Still can't see anything?
"ol
!
. Set the illuminator output to maximum

. Remove the narrow band filter

. increase the exposure to the maximum possible at th

. increase the electrical gain to 4X
- Remove the reticle entirely

Still can't see anything?

) I

till can't see anything?

HS%& : (

e current frame rate

file://C:\Users\Sam Powers\AppData\Local\Temp\~hB8Bhtm 6/23/200!



Getting Starte Page9 of 14

1)

Once you find the image
Reduce the illuminator intensity and focus carefully.

Pan and zoom

You may zoom in on small areas of the image for closer inspection. It is possible to zoom in so that only a few
pixels fill the entire screen.
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Zoom in;
Place the mouse cursor on the area that you wish to view, and click the right mouse button.

A magnifying glass cursor appears, as shown below. The magnification change occurs when you release the
mouse button. The feature under the magnifying glass cursor now is located in the center of the image.
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TIP: £5ch click increases magnification by a factor of approximately 2X.

Zoom out:
Click the smaller magnifying glass in the upper left corner of the video window.

Pan:
The scroll bars permit panning to view different areas of the image.

Press the right mouse button to zoom in.
Keep doing this until you can see individual pixels.
Zoom back out by pressing the icon in the upper left corner of the image area.

Continue to next page

Making a measurement

PixelScope analysis functions are grouped into Tools and Wizards.

Tools

Tools operate on a selection area dragged with the mouse. Selecting one of the tools causes a plot window to
open automatically. Tools may be selected from the buttons on the left side of the main window or from the Tools
menu.

Wizards
Wizards perform more elaborate analysis tasks Each Wizard has a dedicated control window, and some have
dedicated output windows also. Wizards are not available in PS-Pro.

The Tools and Wizards sections explain the available functions. The remainder of this section gives an overview
on how to make your first measurement.

The Selection area

PixelScope's tools operate on a subset of the image called the Selection area . You create the selection area by
dragging with the left mouse button. This Selection area may be as small as a single pixel or as large as the
entire image.
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TIP: The cursor changes shape when you move the mouse over an existing Selection area . The mouse may
be used to change the size or location of the Selection area.

- Open an image.
Drag with the left mouse button to create a selection area box.
Notice that when you move the mouse over the selection area the cursor changes shape.
Practice adjusting the size of the selection area with the mouse.
Use the right mouse button to zoom in. Notice that the selection area remains constant.

Opening a tool

A tool is selected by pressing one of the tool buttons shown below. Only one tool may be active at a time.
The same options are also available on the Tools menu.

FAYIY Cross section tool

”Uh]. Histogram tool

Feature location tool

_H\' Caliper tool

+_.u# Contrast measurement tool

Select contrast measurement tool by pressing the button shown above. The plot window opens
automatically.

Drag a selection rectangle with the mouse.
View the results. The plot window opens automatically.
Use the mouse to change the size and/or location of the selection area, and notice that the plot updates
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Most tools can operate in either X or Y as shown below:

X direction button is active. Note the orientation of the selection area.

1700 00 500

Soplc i s in 00 v B e gy

Y direction button is active. Note the orientation of the selection area.
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Practice switching the contrast tool between X and Y directions.

Continue to next page

Next steps

Lessons learned

If you have followed the short tutorial in this section, you now know how to:

- View live video or Load a saved image

- Pan and zoom to inspect a particular area of the image
- Drag a rectangular selection area with the mouse
- Activate a tool to analyze the selected area in either X or Y

If you are not familiar with any of these techniques we recommend you take a moment to review them now.

What to do next

. We hope you have been following the suggestions to "try it now." If so, you are probably pretty
comfortable with PixelScope's basic operation.

- If not, this would be a great time to unpack the hardware, set it up, and capture some images.
. What you do next depends on your personal learning style. Do you love to read manuals? (you're
reading this, after all..) If so, you should skim the rest of this document to familiarize yourself with

PixelScope's features.

. If you're not an inveterate manual reader, then just start using PixelScope. All the features are available on
the menus--there are no hidden features. We urge you to explore the menus and become familiar with their
layout.
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- When you find an item you aren't familiar with, press F1 to bring up context-sensitive help.

. We're always interested in suggestions on how we can improve PixelScope. If you have an idea for a
feature you can't live without, send an email to ben@wellsresearch.com.
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